Skip to content

Harvester Terraform Provider

Requirements

  • Terraform >= 0.13.x
  • Go 1.16 to build the provider plugin

Install The Provider

copy and paste this code into your Terraform configuration. Then, run terraform init to initialize it.

terraform {
  required_providers {
    harvester = {
      source = "harvester/harvester"
      version = "<replace to the latest release version>"
    }
  }
}

provider "harvester" {
  # Configuration options
}

Using the provider

More details about the provider-specific configurations can be found on the docs.